Checkouts with a specified Fixed Amount or Fixed Price may be unable to complete the flow

Incident Report for Patch

Resolved

This incident has been resolved.
Posted Jun 24, 2024 - 14:39 PDT

Update

We are continuing to investigate this issue.
Posted Jun 24, 2024 - 12:12 PDT

Investigating

We are currently investigating this issue.
Posted Jun 24, 2024 - 11:21 PDT
This incident affected: Patch Platform.